파이썬 opencv 다운로드

6 de fevereiro de 2020, em

이것은 오류 오류에 대한 내 해결책이었다 : 요구 사항을 맞는 버전을 찾을 수 없습니다 opencv-contrib-파이썬 (버전에서 : 없음) 오류 : 내가 더 이상 파이썬을 지원하지 않지만 Raspi 제로 W에 opencv-contrib-파이썬에 대한 검색 배포판은 PyImageSearch에 공식적으로 파이썬 2.7을 지원하지 않습니다. 당신은 파이썬 3 하나 대신 파이썬 2.7 가상 환경을 만들려면 : 나는 다음과 같은 문제가 “요구 사항을 맞는 버전을 찾을 수 없습니다 opencv-contrib-python (버전에서 : ) opencv-contrib-python에 대한 일치하는 배포판이 없습니다 ” 어떤 도움도 환영합니다. 지난 번에 나는 오랜 시간이 걸렸다 라즈베리 파이에 opencv를 컴파일. 😉 “핍 설치 opencv-contrib-python==3.4.3” GPU를 활용 하거나 CPU 전용 기능입니다??? OpenCV가 GPU를 사용하려면 소스에서 OpenCV를 컴파일해야 합니다??? 데이브 존스 (피카메라 파이썬 모듈의 창조자) 그리고 라즈베리 파이 커뮤니티 실행 piwheels.org 벤 Nuttall, ARM 바퀴를 제공 하는 파이썬 패키지 저장소 (즉, 미리 컴파일 된 바이너리 패키지) 라즈베리 파이에 대 한. A: 대부분의 경우 문제는 너무 오래 된 핍관련 이며 pip 설치 –업그레이드 핍을 실행 하 여 해결할 수 있습니다. 휠(특히 많은 리눅스) 형식은 현재 제대로 ARM 아키텍처를 지원하지 않으므로 PyPI에 ARM 기반 플랫폼에 대한 패키지가 없습니다. 그러나, 라즈베리 파이에 대 한 opencv-파이썬 패키지 https://www.piwheels.org/ 찾을 수 있습니다. 나는 친구의 노트북 (윈도우 10)에 `pip3 설치 opencv-contrib-파이썬`을 시도하고 일했다! 그냥 당신이 안전 측면에있을 `버추얼 엔프 `와 `버추얼 vwrapper`를 사용하여 그것을 할 수 있는지 확인하십시오. 당신은 OpenCV와 파이썬에 대한 자세한 내용을 원한다면 나는 M. Beyeler에 의해 파이썬 청사진OpenCV를 읽는 것이 좋습니다 : C ++, 파이썬과 자바 인터페이스는 리눅스를 지원, 맥 OS, 윈도우, 아이폰 OS, 안드로이드. RPi 3B +에 핍 opencv-contrib-파이썬의 설치가 작동하지 않았다.

– Raspbian 스트레치 클린 설치 를 실행 – 가상 환경을 설치하고 잘 작동하는 것 같다 – 설치 절차가 성공적으로 완료 – 나는 가상 환경에 들어갈 작업 이력서를했다 – 도움말() 모듈은 cv2가 존재한다는 것을 보여줍니다 – 가져 오기 cv2 오류 메시지에 결과: “ImportError: libcblas.so.3: 공유 개체 파일을 열 수 없습니다: 이러한 파일 또는 디렉토리 없음” 우리는 파이썬 3.6.8을 선택 하는 순간에 이 문서를 작성 하 고 (3 월 2019) 다른 외부 라이브러리에 의해 최고의 지원 되는 버전 컴퓨터 비전에 필요한 경우. 안녕! 애드리안, 처음에 나는 opencv3.4.1 이미 “Gstreamer”와 같은 모든 기능을 설치하고 opencv 3.4.3 모든 기능이 비활성화된 “핍 설치”comand로 업데이트 한 후 ….


Por Paula Brasiel

Mineira, enfermeira de formação e libriana vaidosa e organizada! É cheia de planos na vida, e um deles é este blog!

Deixe o seu comentario

Os comentários estão desativados.